小黑屋|Klipper玩客 ( 桂ICP备13004039号-7 )

GMT+8, 2024-6-24 14:10

Powered by Discuz! X3.5

© 2001-2024 Discuz! Team.

【求助】上位机和下位机总是莫名断开

407
5
0
0
miao_o LV2
正文
发布时间:2023-04-29
我的T机 刚开始购入的时候就发现使用自带的那个屏幕软件打印开始没几秒屏幕软件就会卡住不动了,但是打印机还在正常运行,而屏幕软件每次永远停留在开始打印预热的那前几秒。

本来以为只是那个屏幕软件不好用 等换klipper之后应该会好了
可是没想到 棒子和T机刷了kilpper安到hub上连接,还是会一会自动上下位机失联,没有任何规律,而且用了klipper后失联打印机直接很停止,还不如原版的屏幕软件,至少那个屏幕软件断了打印机还会正常运行。
上位机换了好几个棒子和USB hub都是一样的结果,手头没有多余的这种方口连接线不知道是不是连接线的问题,已经在买了。
也不确定是不是我hub的问题,这个拓展坞不知道为何明明应该5v就可以连接打印机和WiFi棒子,而我的只有用了65w的充电头才能使棒子和打印机联通,用5w的充电头永远连不上下位机。有没有用过的大佬指导下。之前有大佬说是充电头协议的问题,我换了三四个头加上各种插线板的USB接口都不行。
每次断连前一两秒可以听到轻轻的一声应该是电机断电的声音,但就那一下下其余的风扇和主板的灯还是正常运行着,然后kilpper里就会出现下位机失联的提示,之后无论怎么开关上下位机插拔电源等等,就很难会再次恢复连接了。不知为何断联前会出现一声很轻的类似电机断电的声音,基本正常运行中我把上下位机断开也不会出现那种声音。
困扰我好些天了,求各位大佬帮忙看看,顺便看看有没有一样自带屏幕软件会打印卡住进度的朋友以便我更好确定下故障原因,感谢
IMG_20230429_143109.jpg
IMG_20230429_143057.jpg
IMG_20230429_143653.jpg

回复

 

全部评论 共 5 个

miao_o LV2

miao_o 发表于 2023-4-30 20:13 显示全部楼层

进kiauh里看到的MCU是正常的 但网页端里面显示的却是连不上,即便连上也会随机断联,但是即便断了kiauh里是一直能看到USB里的MCU。难道是主板的问题嘛,在没刷klipper之前大家原本的虚拟屏幕软件有没有和我一样打印断联的吗

super-normal LV2

super-normal 发表于 2023-4-30 20:50 显示全部楼层

我还没刷没刷klipper,用SD卡自动打印,结果原点不对拉面条了。然后直接关机,再重新开机的时候连虚拟屏就提示和主板通信失败,反复开机几次后又能连上了。失联期间挤出机风扇一直转,然后突然执行了一个打印结束的动作,就连上了:dizzy:

文一 LV2

文一 发表于 2023-5-1 13:18 显示全部楼层

可能首先要考虑棒子过热,以及hub的稳定性。

文一 LV2

文一 发表于 2023-5-1 13:18 显示全部楼层

可能首先要考虑棒子过热,以及hub的稳定性。

miao_o LV2

miao_o 发表于 2023-5-2 17:25 显示全部楼层

本帖最后由 miao_o 于 2023-5-2 17:27 编辑

破案了,果然是自带的那根方口数据线有问题,买了根新的瞬间不断连了普通5v充电头也可以连接打印机了
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表